Driver App Validation Issues
Incident Report for EverDriven
Resolved
We have resolved this issue and systems are operating normally.
Posted Jan 13, 2022 - 09:06 MST
Investigating
We are receiving reports of issues with driver app logins. Researching the issues.
Posted Jan 13, 2022 - 08:34 MST
This incident affected: Driver App.