Driver App Issues
Incident Report for EverDriven
Resolved
Calling an all-clear. Any drivers experiencing issues should update to the latest version of the Driver App. If issues continue after updating, please contact Driver Support.
Posted May 23, 2022 - 07:34 MDT
Monitoring
Please update to the latest version of the Driver App to see if this resolves the issue with accessing it. If drivers are still not able to access the app, please contact Driver Support.
Posted May 23, 2022 - 07:19 MDT
Investigating
As of 3:15 PDT today we we have been seeing intermittent issues with accessing the Driver App and are investigating.
Posted May 23, 2022 - 05:37 MDT
This incident affected: Driver App.